Browse Search Popular Register Upload Rules User list Login:
Search:
Spawn Engine Bug...Help?

Image:
screenshot of the scene

Author: CopenhagenEngineer

Group: Default

Filesize: 3.27 MB

Date added: 2015-07-20

Rating: 5

Downloads: 266

Views: 153

Comments: 4

Ratings: 1

Times favored: 0

Made with: Algodoo v2.1.0

Tags:

Scene tag

Hey guys. I have a weird bug with this engine, I can't figure out what it is.

It runs just fine, but it won't accelerate. It seems like the idler laser has the control, and for some reason the accelerate laser doesn't update or something. None of my engines have done this before, someone help me out please:tup:
Please log in to rate this scene
edit
Similar scenes
Title: car with I4 spawn engine
Rating: 7.0834
Filesize: 74.51 kB
Downloads: 2593
Comments: 9
Ratings: 6
Date added: 2009/12/03 02:39:30
Made with: Phun
Rating: rated 7.1
download
Title: V10 Spawn Engine Version 1
Rating: 5.5
Filesize: 59.48 kB
Downloads: 1109
Comments: 2
Ratings: 2
Date added: 2015/01/17 16:43:48
Made with: Algodoo v2.1.0
Rating: rated 5.5
download
Title: My Spawn Engine(HIGH TORQUE!!)
Rating: 5.1111
Filesize: 54.74 kB
Downloads: 632
Comments: 2
Ratings: 3
Date added: 2015/05/24 10:26:31
Made with: Algodoo v2.1.0
Rating: rated 5.1
download
Title: 5cylinder spawn Bus/spawn otobŁs
Rating: 6
Filesize: 267.18 kB
Downloads: 1206
Comments: 1
Ratings: 3
Date added: 2011/08/05 16:12:59
Made with: Algodoo v1.8.5
Rating: rated 6
download
Title: Spawn engine
Rating: 5
Filesize: 16.87 kB
Downloads: 485
Comments: 0
Ratings: 1
Date added: 2014/12/14 14:10:08
Made with: Algodoo v2.1.0
Rating: rated 5
download
Title: 8 Cylinder 4 Stroke Spawn Engine
Rating: 5.5
Filesize: 68.8 kB
Downloads: 1264
Comments: 3
Ratings: 2
Date added: 2012/10/28 03:11:34
Made with: Algodoo v2.0.2 Edu
Rating: rated 5.5
download
Actually using lasers to control things is terribly outdated. use this script on the spawn script (replace density := (scene.my.acc) with this:)

density := (keys.isDown("up")? 500:10);

So, when you press the key stated (it can be "w", "up", "right", "tilde", or whatever, but it HAS TO BE BETWEEN COMMAS) then the script will output 500 (you can change that at your will), and if you don't press the key then it will output 10 (or whatever)
also move the second circle (the one where the other circles are spawned, not the one with the script) to the center as this will give you more powarr, and write vel := entity.vel too. this will ensure that the ball is spawned at the same speed that the car goes
Well Linkage, while I don't disagree with you at all, that still doesn't answer my question. I've used this script in 4 different engines, and all of a sudden this time it's just not responding. Doesn't make sense, not at all.

I'm sure if someone who uses this same technique saw, they'd be able to tell me why this is happening.
The blue laser is "behind" the red. When you click on the blue and then shift + scroll (the mouse) to ut it in the front, your motor accelerate.

Is your problem solve ?