Algodoo Open Beta 1.9.7 Released!

Official announcements from Algoryx and the Algodoo team. Updates, official contests, news, etc.

Re: Algodoo Open Beta 1.9.7 Released!

Postby Emanuel » Thu Jun 30, 2011 4:28 pm

Rideg wrote:http://imageshack.us/photo/my-images/9/algodoobeta1106300000.png/

You have to excuse me, I never got the hang of attaching a screenshot directly to the post.

Logfile:
Warning: Failed to serialize texture "texture";
Warning: Found crossing that went unfixed12;
Warning: BOM for UTF-16LE found in text expected to be UTF-812:22:06;
Warning: Missing Svenska translation for "various stuff".

Hmm, are you sure you are running 1.9.7 and did you install it to a new directory?
Have you tried resetting your config?
What graphics card are you running?

Gent wrote:Hinges TOTALY suck, what do they not want us to make engines or cars anymore?

We want you to be able to make better cars, but you are running a beta and we have reworked the solver quite a lot, some bugs are to be expected.

/ Emanuel
Algodoo Developer
Emanuel
 
Posts: 293
Joined: Tue Feb 01, 2011 10:46 am
Location: Umeå, Sweden

Re: Algodoo Open Beta 1.9.7 Released!

Postby Roast Beef » Fri Jul 01, 2011 1:49 am

Was the ability to slow down/speed up the scene removed? It couldn't have been...
cannot find it for the life of me.
Roast Beef
 
Posts: 28
Joined: Tue Sep 08, 2009 11:18 pm

Re: Algodoo Open Beta 1.9.7 Released!

Postby Rideg » Fri Jul 01, 2011 2:06 am

[quote="Emanuel"]Hmm, are you sure you are running 1.9.7 and did you install it to a new directory?[/quote]
You mean installing it without replacing 1.8.5?
User avatar
Rideg
 
Posts: 948
Joined: Tue Dec 15, 2009 5:17 pm
Location: Östersund, Sweden

Re: Algodoo Open Beta 1.9.7 Released!

Postby Emanuel » Fri Jul 01, 2011 7:47 am

Roast Beef wrote:Was the ability to slow down/speed up the scene removed? It couldn't have been...
cannot find it for the life of me.

If you are talking about simulation speed, try holding you mouse over the play button for a second.
Pressing the play button also works (not space that is).

Rideg wrote:You mean installing it without replacing 1.8.5?

Precisely, and resetting you config.

/ Emanuel
Algodoo Developer
Emanuel
 
Posts: 293
Joined: Tue Feb 01, 2011 10:46 am
Location: Umeå, Sweden

Re: Algodoo Open Beta 1.9.7 Released!

Postby Rideg » Fri Jul 01, 2011 3:40 pm

Nothing worked.
User avatar
Rideg
 
Posts: 948
Joined: Tue Dec 15, 2009 5:17 pm
Location: Östersund, Sweden

Re: Algodoo Open Beta 1.9.7 Released!

Postby TC42 » Sun Jul 03, 2011 11:25 pm

Any word on when a Linux version will be available?
User avatar
TC42
 
Posts: 984
Joined: Sun Jan 09, 2011 1:53 pm
Location: $ sudo apt get-install sandwich_

Re: Algodoo Open Beta 1.9.7 Released!

Postby Emanuel » Mon Jul 04, 2011 8:29 am

Rideg wrote:Nothing worked.

Could you please attach your whole Logfile.txt so that I can see if I find something suspicious?

/ Emanuel
Algodoo Developer
Emanuel
 
Posts: 293
Joined: Tue Feb 01, 2011 10:46 am
Location: Umeå, Sweden

Re: Algodoo Open Beta 1.9.7 Released!

Postby Emanuel » Mon Jul 04, 2011 8:32 am

TC42 wrote:Any word on when a Linux version will be available?

Our Linux developer is unfortunately on vacation, so the Linux version will have to wait.

/ Emanuel
Algodoo Developer
Emanuel
 
Posts: 293
Joined: Tue Feb 01, 2011 10:46 am
Location: Umeå, Sweden

Re: Algodoo Open Beta 1.9.7 Released!

Postby Nait » Mon Jul 04, 2011 5:47 pm

Like this beta, but algodoo still crashes when I try to use hinges/drag tool... What can cause this?
User avatar
Nait
 
Posts: 224
Joined: Fri Oct 30, 2009 1:56 am
Location: Eastern Russia, Vladivostok

Re: Algodoo Open Beta 1.9.7 Released!

Postby electronicboy » Mon Jul 04, 2011 6:07 pm

[quote="Emanuel"][quote="TC42"]Any word on when a Linux version will be available?[/quote]
Our Linux developer is unfortunately on vacation, so the Linux version will have to wait.

/ Emanuel[/quote]

How long has he been on vacation?
And when is he due back?

Also, could you tell him to read his [damn] messages

Ps, current algodoo deb wont install due to bad user IDs on the files....
Tar.gz version works fine!
electronicboy
 
Posts: 1693
Joined: Mon Aug 31, 2009 6:18 pm

Re: Algodoo Open Beta 1.9.7 Released!

Postby tatt61880 » Wed Jul 06, 2011 12:50 am

Thanks for adding changelog into this topic's first post. :thumbup:

Since v1.9.7b has been released, lots of bugs seems to be fixed.
Please release next beta for increasing our motivation. ;)

Regards,
Tatt
NOTE: I'm not an Algoryx member.
Hi, Algodoo lovers. Have you read next topic? Featured scenes suggestions
To translators: English.cfg changelog will be useful (even for me).
User avatar
tatt61880
[Most Helpful Person 2010]
 
Posts: 1150
Joined: Mon Aug 31, 2009 5:45 pm
Location: Tokyo, Japan

Re: Algodoo Open Beta 1.9.7 Released!

Postby byunghoon.cho » Wed Jul 06, 2011 9:29 am

T O O L A G G Y ! ! !
So laggy that I just uninstalled it
byunghoon.cho
 

Re: Algodoo Open Beta 1.9.7 Released!

Postby electronicboy » Wed Jul 06, 2011 7:03 pm

*byunghoon.cho*
T O O L A G G Y ! ! !
So laggy that I just uninstalled it
*
I am going to premube you are a windows user...

Please try the 1.8.5 (on the downloads page) and tell me if that is also laggy.
Do you know your computers specs?

Also, could you please post the contets of
My documents/algodoo/logfile.txt

Also, could you please do this
1. Press start (and run if using XP) and type 'dxdiag' and press enter

2. Give the program a minute to load everything
(if a message about WHQL or something similar, click yes or no (your choise))

3. Click the button at the bottom of the screen, (save to file) and save the file...

4. Please paste a copy of the contents to this post

If you cant post the files, please send an email with the files attached,

Shane_af (at) yahoo .co .uk
electronicboy
 
Posts: 1693
Joined: Mon Aug 31, 2009 6:18 pm

Re: Algodoo Open Beta 1.9.7 Released!

Postby TC42 » Wed Jul 06, 2011 8:21 pm

Did you reset algodoo's config? It doesn't automatically reset when it installs (I think)... and if you installed it to the same directory as 1.8.5, you may get lag. If you're moving from phun to algodoo, algodoo may lag slightly more than phun, I think.
User avatar
TC42
 
Posts: 984
Joined: Sun Jan 09, 2011 1:53 pm
Location: $ sudo apt get-install sandwich_

Re: Algodoo Open Beta 1.9.7 Released!

Postby mattias73 » Tue Jul 12, 2011 10:31 am

Are the force vectors not available/turned of in this beta-version, or am I just incompetent in finding them?

Cheers!
Mattias
mattias73
 
Posts: 9
Joined: Tue Jul 12, 2011 9:56 am

Re: Algodoo Open Beta 1.9.7 Released!

Postby mattias73 » Tue Jul 12, 2011 10:44 am

Bug: Turning of "show momentum" or "show force" in the general settings, then turning it on for a specific object, then going back to the general settings for showing forces etc made the dialog window "flickr".

Using the mac-version.
mattias73
 
Posts: 9
Joined: Tue Jul 12, 2011 9:56 am

Re: Algodoo Open Beta 1.9.7 Released!

Postby Rideg » Fri Jul 15, 2011 12:05 am

So, my old computer crashed but I've got a new one now. Algodoo opens pretty slow and 'Load scenes' have the same issue. I think that the window that pops up when Algodoo opens with a text like"please wait ...while gravity is being created" shouldn't overlap everything as it blocks 1/5, 1/4 of the screen. Other than that, nothing to report.
User avatar
Rideg
 
Posts: 948
Joined: Tue Dec 15, 2009 5:17 pm
Location: Östersund, Sweden

Re: Algodoo Open Beta 1.9.7 Released!

Postby gloix » Fri Jul 15, 2011 7:19 am

Hi there. Got some bugs to report:
- When I try to make a chain quickly and then run the simulation Algodoo crashes. This happens also when I'm making it with sim running.
- When I start the program, I notice it starts as maximized but it's not. I mean that it doesn't cover the hole screen, but when I try to maximize it, it just get smaller, then I try to maximize it and then it works.
- Algodoo also crashes when I liquify a considerable amount of matter.
gloix
 

Re: Algodoo Open Beta 1.9.7 Released!

Postby electronicboy » Fri Jul 15, 2011 10:27 pm

1. There is a known bug with the new solver that causes chains to crash, this is going to be fixed/ has been fixed it in-house version
2. I also experience that problem.... lets hope for fix!
3. This is caused by too much strain on your cpu.. remember, the more objects (and water (a special kind of object)), the more work algodoo has to do.
electronicboy
 
Posts: 1693
Joined: Mon Aug 31, 2009 6:18 pm

Re: Algodoo Open Beta 1.9.7 Released!

Postby Chronos » Sat Jul 16, 2011 6:48 am

Gloix, that's the same thing that happens to me, to the letter. And you, perchance, using an ATI/AMD graphics card?
User avatar
Chronos
[Most Active Member 2010]
 
Posts: 4457
Joined: Mon Aug 31, 2009 6:00 pm
Location: Californania

Re: Algodoo Open Beta 1.9.7 Released!

Postby gloix » Tue Jul 19, 2011 7:58 am

[quote="Chronos"]Gloix, that's the same thing that happens to me, to the letter. And you, perchance, using an ATI/AMD graphics card?[/quote]
Yes. Radeon HD6370
gloix
 

Re: Algodoo Open Beta 1.9.7 Released!

Postby Someone Else » Tue Jul 19, 2011 8:54 pm

I've found that with the maximized/not maximized bug, if you click outside the Algodoo window after the window appears but before Algodoo fully loads, it fixes itself for the session.
User avatar
Someone Else
 
Posts: 1147
Joined: Sun Nov 21, 2010 10:53 pm
Location: The Milky Way Galaxy

Previous

Return to Official announcements

Who is online

Users browsing this forum: No registered users and 0 guests

cron